LibraryLink ToToggle FramesPrintFeedback

Java and Compiler Requirements

To run applications developed with Apache Camel, you must have JRE 1.5.0_11 or newer.

To develop applications using Apache Camel, you must have JDK 1.5.0_11 or newer.

It is also recommended that you have Apache Ant 1.6.5 or higher. The sample programs supplied with Apache Camel are set up to build and run using Apache Ant. You can download Apache Ant from http://ant.apache.org/bindownload.cgi.

[Important]Important

Only JREs and JDKs distributed or OEMed from Sun Microsystems are supported. (That is, Apache Camel is not guaranteed to run with gcj.) On Red Hat-derived Linux systems, gcj is the default Java distribution. In these cases, you must download and install a Sun JRE/JDK and set the JAVA_HOME environment variable. You can also integrate the Sun JRE/JDK into the alternatives(1) system. See the alternatives(1) man page for details.