Forum Home » Fuse Distributions » Fuse Services Framework

Thread: Installing Services Framework

 

Permlink Replies: 5 - Last Post: Apr 20, 2009 10:21 AM Last Post By: seanoc
ee7arh

Posts: 13
Registered: 04/20/09
Installing Services Framework
Posted: Apr 20, 2009 8:16 AM
  Click to reply to this thread Reply
Hi,

Seems like a really obvious question but I spent 15 minutes already trying to figure it out without luck.

I downloaded already the messagebroker, the mediation router and now Fuse Services Framework. In the latter 2, when i install the binaries in Windows I have a lib directory with all the jar files within.

However with Services Framework I see only an etc, conf and uninstall directory. Am I missing something here? I need the jar files so I can use this in my application.

Any ideas?

Cheers
Andy
seanoc

Posts: 96
Registered: 09/05/08
Re: Installing Services Framework
Posted: Apr 20, 2009 9:25 AM   in response to: ee7arh in response to: ee7arh
  Click to reply to this thread Reply
Hi Andy,

Which version of SF are you trying to install, can you send me on the exact link to the installer you used , so I can have a look at it.

Seán.
ee7arh

Posts: 13
Registered: 04/20/09
Re: Installing Services Framework
Posted: Apr 20, 2009 9:36 AM   in response to: seanoc in response to: seanoc
  Click to reply to this thread Reply
Hi Sean,

Just navigated through from fusesource homepage -> downloads -> Service Framework ->

http://fusesource.com/download?file=http://repo.fusesource.com/maven2/com/iona/fuse/fuse-services-framework/2.2.0.0/fuse-services-framework-2.2.0.0-windows.exe&desc=FUSE+Services+Framework

BRegards
Andrew

p.s. I downloaded the linux version onto my linux machine and this was ok
seanoc

Posts: 96
Registered: 09/05/08
Re: Installing Services Framework
Posted: Apr 20, 2009 9:55 AM   in response to: ee7arh in response to: ee7arh
  Click to reply to this thread Reply
Hi Andy,

Not sure what is going on for you but using the link you posted, I installed the SF and using the default install directory I have a lib directory: C:\progress\fuse-services-framework-2.2.0.0\lib which contains all the required jars.

Perhaps try downloading a new installer or run again.

FYI: This was on Windows XP SP3.

Seán.
ee7arh

Posts: 13
Registered: 04/20/09
Re: Installing Services Framework
Posted: Apr 20, 2009 10:05 AM   in response to: seanoc in response to: seanoc
  Click to reply to this thread Reply
Hi Sean,

Thanks. I also managed to do that fine now.

Could be the problem is related to choosing your own directory then or a conflict with messaged broker / mediation router

I created a dir "C:\fuse" first, then installed fuse activemq / camel into that sub dir, then finally tried to installed service framework

so I ended up with these 3 dir:

C:\fuse\fuse-mediation-router-1.5.4.0
C:\fuse\fuse-message-broker-5.3.0.0
C:\fuse\fuse-services-framework-2.2.0.0

The 1st 2 seemed to install fine but service framework was somewhat lacking ;)

The default directory however works fine. I am also XP service pack 3

BRegards
Andy
seanoc

Posts: 96
Registered: 09/05/08
Re: Installing Services Framework
Posted: Apr 20, 2009 10:21 AM   in response to: ee7arh in response to: ee7arh
  Click to reply to this thread Reply
Hi Andy,

Yes there is a problem if one chooses a non-default directory.
I have raised this as a bug. http://fusesource.com/issues/browse/SF-190

Thanks very much for pointing this out.

Regards,

Seán.