Forum Home » Projects » Fuse IDE 1.0

Thread: Installation missing requirement

 

Permlink Replies: 8 - Last Post: Jun 28, 2011 6:42 PM Last Post By: lhein
kris_moens@yaho...

Posts: 4
Registered: 06/17/11
Installation missing requirement
Posted: Jun 17, 2011 1:49 PM
  Click to reply to this thread Reply
Hi,

I try to install the Fuse IDE 1.1.4 through a local update center (point to the unzipped tar.gz I got from repo.fusesource.com), but got the following error:

Cannot complete the install because one or more required items could not be found.
Software being installed: Fuse IDE for Camel 1.1.4 (com.fusesource.rider.feature.feature.group 1.1.4)
Missing requirement: Fuse IDE for Camel 1.1.4 (com.fusesource.rider.feature.feature.group 1.1.4) requires *'org.eclipse.zest.core 0.0.0' *but it could not be found

Since the environment is shielded from the www, I cannot use the software sites on the internet.
Using eclipse helios 3.6.2
davsclaus

Posts: 1,893
Registered: 10/14/08
Re: Installation missing requirement
Posted: Jun 18, 2011 8:17 AM   in response to: kris_moens@yaho... in response to: kris_moens@yaho...
  Click to reply to this thread Reply
Hi

1.1.4 is a rather old release. There is a 1.1.32 out. Can you try with that version?

There is an updated install guide
http://fusesource.com/docs/ide/camel/1.0/install_guide/install_guide.html

And at the repo you can see the Fuse IDE repo
http://repo.fusesource.com/
kris_moens@yaho...

Posts: 4
Registered: 06/17/11
Re: Installation missing requirement
Posted: Jun 20, 2011 12:18 PM   in response to: davsclaus in response to: davsclaus
  Click to reply to this thread Reply
thanks for the reply, but same result with the 1.1.32...

Cannot complete the install because one or more required items could not be found.
+ Software being installed: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)+
+ Missing requirement: Maven Integration for Eclipse (Editors) 0.12.1.20110112-1712 (org.maven.ide.eclipse.editor 0.12.1.20110112-1712)+ requires 'bundle org.eclipse.zest.core 0.0.0' but it could not be found
* *Cannot satisfy dependency:
+ From: Maven Integration for Eclipse (Required) 0.12.1.20110112-1712 (org.maven.ide.eclipse.feature.feature.group 0.12.1.20110112-1712)+
+ To: org.maven.ide.eclipse.editor http://0.12.1.20110112-1712+

Even if I deselect the (required) Maven plugin,I still need the same zest core bundle:

Cannot complete the install because one or more required items could not be found.
+ Software being installed: Fuse IDE for Camel 1.1.32 (com.fusesource.rider.feature.feature.group 1.1.32)+
+ Missing requirement: Fuse IDE for Camel 1.1.32 (com.fusesource.rider.feature.feature.group 1.1.32) requires 'org.eclipse.zest.core 0.0.0' but it could not be found+

Any other suggestions?

Tx

Kris
davsclaus

Posts: 1,893
Registered: 10/14/08
Re: Installation missing requirement
Posted: Jun 20, 2011 3:05 PM   in response to: kris_moens@yaho... in response to: kris_moens@yaho...
  Click to reply to this thread Reply
Try with a fresh installation of Eclipse
jstrachan

Posts: 43
Registered: 08/10/07
Re: Installation missing requirement
Posted: Jun 21, 2011 7:42 AM   in response to: davsclaus in response to: davsclaus
  Click to reply to this thread Reply
I think the problem may be to do with offline installations; our Update Site doesn't include eclipse, zest & m2eclipse as we'd assumed when creating the Update Site that Eclipse would install those pieces from the correct place.

So for offline installations, it looks like we'd need to put eclipse/zest/m2eclipse on a CD too.

For offline installations it might be better to create a full stand alone installations of Eclipse with Fuse IDE; so there's no online update site requirement. I've raised an issue to track this (ECLIPSE-267).

In the meantime, we could maybe try copying the helios & m2eclipse update sites onto a CD so you can install offline? Or maybe someone could install online, then copy the installation to a CD?
kris_moens@yaho...

Posts: 4
Registered: 06/17/11
Re: Installation missing requirement
Posted: Jun 22, 2011 1:25 PM   in response to: jstrachan in response to: jstrachan
  Click to reply to this thread Reply
Thank you James.

Some updates from my side:

Inspired by your reply I tried with the GEF-zest sdk (from http://www.eclipse.org/downloads/download.php?file=/tools/gef/downloads/drops/3.6.2/R201102251600/GEF-zest-sdk-3.6.2.zip) and after adding this I was able now to install the Fuse IDE.

So far so good, but too beatufil to be true ;)

Now I cannot see the Preferences nor that the New>Project>Others>Fuse IDE appears (yes, I restarted eclipse) :(

So, the plug-in was installed (I can even browse through it in the installed components), but it is not made available as such that I can create Camel projects or look at the Window>Preferences for Fuse IDE.

I might be related to the version of GEF-zest I downloaded (in meantime I tried a few of them already without any result) or maybe I still miss some components which are needed under the cover?

BRs,
Kris

Edited by: kris_moens@yahoo.com on Jun 28, 2011 9:18 AM
lhein

Posts: 72
Registered: 11/18/08
Re: Installation missing requirement
Posted: Jun 23, 2011 2:29 PM   in response to: kris_moens@yaho... in response to: kris_moens@yaho...
  Click to reply to this thread Reply
That somehow sounds like there are some missing bundles which prevent the Fuse bundles to be loaded correctly. Could you check if the Fuse IDE feature is listed if you look at "About >> Installation Details >> Features" menu.

Regards
Lars
kris_moens@yaho...

Posts: 4
Registered: 06/17/11
Re: Installation missing requirement
Posted: Jun 28, 2011 9:17 AM   in response to: lhein in response to: lhein
  Click to reply to this thread Reply
Thanks Lars.

I checked your suggestion and indeed Fuse IDE is missing from the "Features" list...

Although it appears under the "Installed Software" tab, and I see the following in the Plug-ins list:
  • Fuse IDE for Camel Commons Plugin
  • Fuse IDE for Camel SUS Plugin
  • Fuse IDE for Camel Maven Plugin
  • Fuse IDE Help Plugin

I had a look on the filesystem and the eclipse features folder does contain a folder "com.fusesource.rider.feature_1.1.32"

Any idea what could prevent loading the Fuse IDE feature (is there somewhere an eclipse log file that is populated during startup?)

BRs
Kris
lhein

Posts: 72
Registered: 11/18/08
Re: Installation missing requirement
Posted: Jun 28, 2011 6:42 PM   in response to: kris_moens@yaho... in response to: kris_moens@yaho...
  Click to reply to this thread Reply
Please check inside the folder you specified as your workspace root. There should be a hidden folder called ".metadata" which contains a hidden file ".log".

If you find it then delete it and startup your eclipse again so only the latest errors are inside. Then provide this file here or via mail to lhein@fusesource.com.
Maybe I can find some hints inside the log.

Thanks in advance
Lars