Forum Home » Projects » Fuse IDE 1.0

Thread: Can't install FuseIDE on Eclipse 6

 
This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 10 - Last Post: Jul 2, 2012 9:33 AM Last Post By: nicolasduminil Threads: [ Previous | Next ]
nicolasduminil

Posts: 87
Registered: 02/24/09
Can't install FuseIDE on Eclipse 6
Posted: Apr 16, 2012 4:41 PM
 
  Click to reply to this thread Reply
Greetings,

Trying to install the FuseIDE in Eclipse 6 (JBoss Developer Studio 4.1.2). I get the following error message:

Software being installed: Fuse IDE 2.0.26 (com.fusesource.rider.feature.feature.group 2.0.26)
Missing requirement: Fuse IDE 2.0.26 (com.fusesource.rider.feature.feature.group 2.0.26) requires 'org.w3c.dom.smil 1.0.0' but it could not be found

I have googled around to find the missing element but no success. Please help.

Kind regards,

Nicolas
davsclaus

Posts: 1,893
Registered: 10/14/08
Re: Can't install FuseIDE on Eclipse 6
Posted: Apr 17, 2012 10:39 AM   in response to: nicolasduminil in response to: nicolasduminil
 
  Click to reply to this thread Reply
Eclipse 6? Do you mean Eclipse 3.6?

Fuse IDE supports the vanilla Eclipse versions you can download from Eclipse.

The upcoming Fuse IDE 2.1 supports the latest Eclipse 3.7 release.
And we will also offer a standalone download that has all in a single zip file, ready to run out of the box.
nicolasduminil

Posts: 87
Registered: 02/24/09
Re: Can't install FuseIDE on Eclipse 6
Posted: Apr 17, 2012 2:18 PM   in response to: davsclaus in response to: davsclaus
 
  Click to reply to this thread Reply
Yeah, thanks, I ment Eclipse 3.6. So, what about my question concerning this error when trying to install FuseIDE ?
ganeshperiasamy

Posts: 3
Registered: 04/17/12
Re: Can't install FuseIDE on Eclipse 6
Posted: Apr 17, 2012 2:30 PM   in response to: nicolasduminil in response to: nicolasduminil
 
  Click to reply to this thread Reply
Even i got the same error when trying to install Fuse to eclipse heleo and indigo.
But when i install it in eclipse galileo(3.5), it installed without any issue, but still i m not seeing 'fuse IDE' perspective in the eclipse.

  • Ganesh
davsclaus

Posts: 1,893
Registered: 10/14/08
Re: Can't install FuseIDE on Eclipse 6
Posted: Apr 17, 2012 2:58 PM   in response to: ganeshperiasamy in response to: ganeshperiasamy
 
  Click to reply to this thread Reply
Hi

Can you try downloading the Fuse IDE 2.1 public beta from
http://fusesource.com/products/fuse-ide/

There is a Fuse 2.1 Beta, tab you should click.
Then you can download for Windows, Mac, Unix etc.
nicolasduminil

Posts: 87
Registered: 02/24/09
Re: Can't install FuseIDE on Eclipse 6
Posted: Apr 19, 2012 2:29 PM   in response to: davsclaus in response to: davsclaus
 
  Click to reply to this thread Reply
I don't like betas, I prefer stable releases. Question again: does the stable release work with Eclipse 3.6 and, if yes, how, as in my case it raises the mentioned exception.

Kind regards
lhein

Posts: 72
Registered: 11/18/08
Re: Can't install FuseIDE on Eclipse 6
Posted: Apr 19, 2012 2:37 PM   in response to: nicolasduminil in response to: nicolasduminil
 
  Click to reply to this thread Reply
Have you tried to install Fuse IDE to a plain Eclipse 3.6 without any JBoss stuff? I know we have compatibility issues with STS for example. I wouldn't wonder if there are also issues with the JBoss version.

Lars
nicolasduminil

Posts: 87
Registered: 02/24/09
Re: Can't install FuseIDE on Eclipse 6
Posted: Apr 23, 2012 10:52 AM   in response to: lhein in response to: lhein
 
  Click to reply to this thread Reply
No, I didn't try as I need to use JBoss Development Studio.
nicolasduminil

Posts: 87
Registered: 02/24/09
Re: Can't install FuseIDE on Eclipse 6
Posted: Apr 24, 2012 7:26 AM   in response to: nicolasduminil in response to: nicolasduminil
 
  Click to reply to this thread Reply
I finally installed Indigo and FuseIDE installs properly on top of it. Copying some plugins, like org.w3c.dom., org.apache.batik., org.apache.derby.*, from the indigo install directory to the JBoss Developer Studio there is no anymore exception during the FuseIDE install, but after the Eclipse restart, FuseIDE doesn't work. You cannot create a FuseIDE project, there is no trace of it. But trying again to install it shows that all components are already installed.

I don't know what to do but I think I'll give it up. I have to use JBDS and I'm developing camel stuff, so FuseIDE would help a lot, but I don't seem to be lucky enough.

Of course, I registered a post on the JBoss forum, as more as it used to work in the previous version of JBDS (4.0) but they say they don't know why this happens. They say that every thing which correctly installs on Helios should install on JBDS as well.
lhein

Posts: 72
Registered: 11/18/08
Re: Can't install FuseIDE on Eclipse 6
Posted: May 4, 2012 7:02 PM   in response to: nicolasduminil in response to: nicolasduminil
 
  Click to reply to this thread Reply
I have logged a Jira for that issue for you to track.

See ECLIPSE-735

Lars

Edited by: lhein on May 4, 2012 9:02 PM
nicolasduminil

Posts: 87
Registered: 02/24/09
Re: Can't install FuseIDE on Eclipse 6
Posted: Jul 2, 2012 9:33 AM   in response to: lhein in response to: lhein
 
  Click to reply to this thread Reply
Thank you.

Nicolas