Forum Home » Enterprise Products » Fuse IDE

Thread: Code completion not working

 
This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 8 - Last Post: May 29, 2012 11:42 AM Last Post By: davsclaus Threads: [ Previous | Next ]
garethahealy

Posts: 88
Registered: 05/01/12
Code completion not working
Posted: May 28, 2012 1:22 PM
 
  Click to reply to this thread Reply
I downloaded the new IDE (v2.1.462) but noticed i wasnt getting any code completion.

Is there a setting i need to turn on? as i just expected it to work out of the box like standard eclipse.
davsclaus

Posts: 1,893
Registered: 10/14/08
Re: Code completion not working
Posted: May 28, 2012 1:34 PM   in response to: garethahealy in response to: garethahealy
 
  Click to reply to this thread Reply
Do you mean code completion like pressing cltr + space and it shows a list of methods, eg in the Java editor?

And where do you expect this code completion? Can you be more specific.
garethahealy

Posts: 88
Registered: 05/01/12
Re: Code completion not working
Posted: May 28, 2012 2:13 PM   in response to: davsclaus in response to: davsclaus
 
  Click to reply to this thread Reply
Yes, when you press ctrl-space.

Below is when in fuse ide:
http://94.236.124.38/fuse-image/fuse.png

Below is when in eclipse (Helios):
http://94.236.124.38/fuse-image/eclipse.png
davsclaus

Posts: 1,893
Registered: 10/14/08
Re: Code completion not working
Posted: May 28, 2012 2:18 PM   in response to: garethahealy in response to: garethahealy
 
  Click to reply to this thread Reply
This is really strange, as the Java editor in Eclipse is the same. eg Fuse IDE is a set of plugins, but the Java editor / perspective is pure Eclipse based.

What OS are you using? And did you download and use the 32bit or 64bit version of Fuse IDE?

And did you use the full installation (on big download). Or did you install Fuse IDE using the plugin center of Eclipse?
davsclaus

Posts: 1,893
Registered: 10/14/08
Re: Code completion not working
Posted: May 28, 2012 2:25 PM   in response to: davsclaus in response to: davsclaus
 
  Click to reply to this thread Reply
You may also be able to see if there is any problems from the "Problems View". Maybe its a project setup thing, with an invalid JDK setting or something.

The Java editor ought to work correctly, if Eclipse / the project is setup correctly.
garethahealy

Posts: 88
Registered: 05/01/12
Re: Code completion not working
Posted: May 28, 2012 3:15 PM   in response to: davsclaus in response to: davsclaus
 
  Click to reply to this thread Reply
OS: Win7 Pro SP1 64bit
FUSE: Full download for 32bit (cant see a windows 64bit download)

Have checked the problems window, and only see warnings related to "class is a raw type" messages. Have also re-installed the IDE just to see if that fixed any issues, which it didnt.
lhein

Posts: 72
Registered: 11/18/08
Re: Code completion not working
Posted: May 29, 2012 8:27 AM   in response to: garethahealy in response to: garethahealy
 
  Click to reply to this thread Reply
Could you please try to create a project using one of our archetypes via Fuse IDE New Project Wizard? My guess is that you might miss some namespace or schema definition in your XML.

Lars
garethahealy

Posts: 88
Registered: 05/01/12
Re: Code completion not working
Posted: May 29, 2012 8:44 AM   in response to: lhein in response to: lhein
 
  Click to reply to this thread Reply
Just fixed the issue. Not sure why/what it was, but reset the defaults via the below screen:

http://94.236.124.38/fuse-image/reset.png
davsclaus

Posts: 1,893
Registered: 10/14/08
Re: Code completion not working
Posted: May 29, 2012 11:42 AM   in response to: garethahealy in response to: garethahealy
 
  Click to reply to this thread Reply
Thanks for sharing your solution.