Forum Home » Enterprise Products » Fuse HQ

Thread: How to set up FUSE HQ to minitor ActiveMQ?

 

Permlink Replies: 3 - Last Post: Sep 3, 2009 5:51 PM Last Post By: saras
janylj

Posts: 2
Registered: 11/18/08
How to set up FUSE HQ to minitor ActiveMQ?
Posted: Nov 18, 2008 11:49 PM
  Click to reply to this thread Reply
I am quite new to FUSE HQ.

First I followed the installation guide for installing both server and agent. For testing purpose, the FUSE server and agent are at one Linux box, which is the same box as ActiveMQ is at. Then I started HQ server and agent. The auto-discovery didn't find ActiveMQ.

Then I went the Platform view and initiate the a new Auto-Discovery and setting "Directories to scan (use , as a delimiter)" to be ActiveMQ installation folder. However, Auto-Discovery results didn't change.

I could manually add ActiveMQ 5.0 server, with "Auto-Discovery for Brokers, Connectors, and other services is ON". But I don't see broker, connector, topic, queue services. Also when I start ActiveMQ, "Process Start Time" in the monitoring tab doesn't update.

Please note that I didn't have ActiveMQ installed at /usr/local/ or /opt. I installed one ActiveMQ under /opt. And HQ still didn't discover it.

So how indeed should I do to set up HQ for ActiveMQ? Does it need some kind of plugin? Thank you very much.

Edited by: janylj on Nov 18, 2008 6:59 PM

Edited by: janylj on Nov 20, 2008 11:36 AM
dgreco

Posts: 7
Registered: 01/12/08
Re: How to set up FUSE HQ to minitor ActiveMQ?
Posted: Nov 24, 2008 8:48 AM   in response to: janylj in response to: janylj
  Click to reply to this thread Reply
Hello,
"theoretically" if everything works well you shouldn't do anything manually for making autodiscovery detecting your AMQ instance.
So, the steps should be just staring the agent, the server and then ActiveMQ using the provided script.
The autodiscovery mechanism works looking for the processes that have the ACTIVEMQ_HOME set up, then it uses this value for checking if under that directory there are the fuse-mb jars.
First of all you have to check if the script you are using is setting the ACTIVEMQ_HOME correctly, for example, if you use the script under
<fuse-mb install dir>/bin/activemq this does set that environment variable, however if you use instead the script under <fuse-mb install dir>/bin/linux-x86-32/activemq this doesn't, and then you have to change it.
You should also use the fuse version of AMQ, the HQ plugin for AMQ has been configured for using the fuse version.
Let me know,
Regards,
David
saras

Posts: 6
Registered: 07/13/09
Re: How to set up FUSE HQ to minitor ActiveMQ?
Posted: Jul 31, 2009 11:36 AM   in response to: janylj in response to: janylj
  Click to reply to this thread Reply
On Win32 platform it is successfully detecting activemq in autodiscovery. However it is unable to detect the queues topics etc. It just shows activemq5.x as available
saras

Posts: 6
Registered: 07/13/09
Re: How to set up FUSE HQ to minitor ActiveMQ?
Posted: Sep 3, 2009 5:51 PM   in response to: saras in response to: saras
  Click to reply to this thread Reply
It is successfully detecting the Message Broker server for 5.x versions(AutoDiscovery). It is also able to detect the Services -topics, queues etc.

In the activemq.xml file you need to make sure that the following statement is there
<managementContext connectorPort=portnum>
(example :<managementContext connectorPort="1099">

It also takes time to detect them so you need to patiently wait for 15-20 minutes.

I tried running some samples too - it is working fine.