Forum Home » Fuse Distributions » Fuse ESB

Thread: JCE cannot authenticate BouncyCastle

 
This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 0
larasith

Posts: 41
Registered: 09/24/10
JCE cannot authenticate BouncyCastle
Posted: Feb 22, 2011 10:02 AM
 
  Click to reply to this thread Reply
I need to use the BouncyCastle JAR to read PKCS 12 keystore, but i ever get this error message:

java.io.IOException: error constructing MAC: java.security.NoSuchProviderException: JCE cannot authenticate the provider BC

I've installed this JAR with the following command:

install wrap:mvn:bouncycastle/bcprov-jdk15

Thanks!

Edited by: larasith on Feb 22, 2011 10:02 AM